mirror of
https://gitlab.com/freepascal.org/lazarus/lazarus.git
synced 2025-04-27 23:03:44 +02:00
41 lines
1.4 KiB
Diff
Executable File
41 lines
1.4 KiB
Diff
Executable File
This patch fixes dist_clean target used to remove generated files before
|
|
packaging sources.
|
|
|
|
diff -urNad lazarus-0.9.26.1-0~/Makefile.fpc lazarus-0.9.26.1-0/Makefile.fpc
|
|
--- lazarus-0.9.26.1-0~/Makefile.fpc 2008-10-11 19:19:59.000000000 +0200
|
|
+++ lazarus-0.9.26.1-0/Makefile.fpc 2008-10-11 19:20:01.000000000 +0200
|
|
@@ -11,7 +11,7 @@
|
|
|
|
[target]
|
|
programs=lazarus startlazarus
|
|
-dirs=lcl packager/registration ideintf packager components
|
|
+dirs=lcl packager/registration ideintf packager components ide tools
|
|
exampledirs=examples
|
|
|
|
[compiler]
|
|
@@ -45,13 +45,9 @@
|
|
|
|
#-----------------------------------------------------------------------------
|
|
[rules]
|
|
-.PHONY: lcl components packager/registration ideintf packager bigidecomponents ide idepkg idebig bigide starter lazbuilder tools all clean cleanide purge examples install lazbuild
|
|
+.PHONY: lcl components packager/registration ideintf packager bigidecomponents idepkg idebig bigide starter lazbuilder tools all clean cleanide purge examples install lazbuild
|
|
|
|
#-----------------------------------------------------------------------------
|
|
-ide:
|
|
- $(MAKE) -C ide ide
|
|
-
|
|
-#-----------------------------------------------------------------------------
|
|
idepkg:
|
|
$(MAKE) -C ide idepkg
|
|
|
|
@@ -82,8 +78,7 @@
|
|
|
|
#-----------------------------------------------------------------------------
|
|
tools: lcl
|
|
- $(MAKE) -C tools
|
|
-
|
|
+
|
|
#-----------------------------------------------------------------------------
|
|
examples: lcl components
|
|
|